2012年6月アーカイブ

CentOS5.2 のpxebootインストール

CentOS5.2 x64 をインストールするという依頼がありcobbler (pxeでインストールするシステム)でできればなぁと思って登録したが動かない。

対象のサーバはHP Proliant BL460 G6という機種で、ネットワークがbnx2xというドライバを使っています。CentOS5.2のinitrd.imgに組み込まれているドライバがどうもダメらしい。

ドライバをコンパイルして、initrd.img を作りなおすことによりpxeインストールは成功しました。

インストール後にbnx2xが動かない。
CentOS5.2で入れているbnx2xのドライバのバージョンは古いため対応していない。このままだと動かないので、cobbler でインストール時にドライバを入れ替えるようにすることにしました。

CentOS5.6あたりのイメージでインストールすると問題無くインストールできるので
5.2あたりだとダメだったんだろう。

後日手順などは追記します。

カテゴリ

ウェブページ

Powered by Movable Type 5.2.10

最近のブログ記事